TWINT is down

Incident Report for Digitalparking AG

Resolved

This incident has been resolved.
Posted Jan 24, 2024 - 09:45 CET

Identified

TWINT is not reachable at the moment
Posted Jan 24, 2024 - 08:46 CET
This incident affected: Parkingpay and TWINT-Parkingpay.